Routine usage within a time period resulted in invalid data
Resolved
Aug 22 at 08:24am CEST
The bug regarding Routines has been fixed, but unfortunately the correct data from that period cannot be recovered.
We will assist the recovery of our customers' operations in the following way:
- Providing a list of the affected Routine Executions that have invalid data.
- Offering to remove the affected Routine Executions.
- Rebuilding the data on Dynamic KPIs that are based on those Routines.
Affected services
API — Lonza
Created
Aug 21 at 01:04am CEST
Due to a regression introduced by a change in the application, from Wednesday 2024-08-21 01:04 PM UTC to Thursday 2024-08-22 8:24 AM UTC, any usage of Routines resulted in invalid data being recorded. This was due to a bug that displayed incorrect Routine Steps when starting, submitting, or editing a Routine Execution; and when editing the Steps of Routines.
When used during that time period, Routines were missing some Steps, or had Steps that were displayed or recorded data in an unexpected way. Therefore, the data on those Routine Executions is invalid and cannot be exploited. Dynamic KPIs based on those Routine Executions will also display incorrect data.
The issue affected the Webapp, the Mobile Application, and the ability to retrieve data from Routines on our public API.
Affected services
API — Lonza