Back to overview
Degraded

Performance Degradation Incident

Apr 23 at 07:17am CEST
Affected services
API — Lonza
Application

Resolved
Apr 23 at 09:36am CEST

The performance issues (including slowness and potential access problems) reported earlier this morning, following our recent system maintenance, have now been fully resolved.

Our team has completed the necessary corrective actions, and all services have returned to normal operation. We have confirmed that system performance is stable.

We apologize for the disruption this may have caused and thank you for your patience and understanding while we worked to resolve it.

Created
Apr 23 at 07:17am CEST

Our monitoring systems have detected performance issues impacting services following overnight maintenance completed early on April 23rd. Users may experience slowness or difficulty accessing the platform. Our engineers are investigating urgently. We apologize for the inconvenience and will share more information shortly.